[haiku-development] Re: RFC: Public header change os/device/graphic_driver.h (was RFC: Thermal sensors in /dev/)

On Mon, 28 Nov 2011 09:35:31 -0600, Alexander von Gluck wrote:
On Mon, 28 Nov 2011 11:56:28 +0100 (MET), Axel Dörfler wrote:
Alexander von Gluck<kallisti5@xxxxxxxxxxx> wrote:
> --- a/headers/os/device/graphic_driver.h
> +++ b/headers/os/device/graphic_driver.h
> @@ -10,7 +10,9 @@ extern "C" {
>  #endif
>
>  enum {
> -       B_GET_ACCELERANT_SIGNATURE = B_GRAPHIC_DRIVER_BASE
> +       B_GET_ACCELERANT_SIGNATURE = B_GRAPHIC_DRIVER_BASE,
> +       B_GET_THERMAL_STATUS,
> +       B_GET_FAN_STATUS
[...]

I don't quite see the point to introduce the graphics driver specific
ioctl in the first place. Why not add the generic ones instead?

Anyway, since this is device meta data, I would like to move stuff
like this into attributes for new device drivers, alongside things
like the serial number, etc.. How and when those attributes are
updated is yet to be determined, though.
This would obviously require quite a number of changes (and more
thought), though.

I definitely agree long term that would be good.
Everything has to start with a first step though :)

Here is something a little more wide spread, I like the metadata idea...

I threw something together...

http://pastebin.com/9Kg7GSQX

I'm guessing I have some names wrong, and the device_attribute category names
probably need expanding.

Thoughts?

-- Alex

Other related posts: