[haiku-development] Re: Coding Style clarification/vote

  • From: "Axel Dörfler" <axeld@xxxxxxxxxxxxxxxx>
  • To: haiku-development@xxxxxxxxxxxxx
  • Date: Wed, 01 Jul 2009 11:35:02 +0200 CEST

Oliver Ruiz Dorantes <oliver.ruiz.dorantes@xxxxxxxxx> wrote:
> > maybe
> >        Class::Class()
> >                : InheritedClass()
> >                , fMember()
> >        {
> >        }
> > with a collon before variable name, as it's easier to for example 
> > add,
> > remove, #ifdef vars ? (that's used at my work and i like that way 
> > :)
> I like this option too, also practical for copy&pasting

It makes me shudder, and really hurts my eyes.
Besides that, the copy&paste thing is not a strong argument IMO; we 
don't write:
        if (a
                && b
                && c
        )
to help that case either, and both should cases should be equally rare. 
So let's just follow the general style used everywhere else.

In general, I think style changes shouldn't end in having to rewrite 
everything, but only should clarify where people don't follow the same 
style, as it's not written down clearly yet.

Bye,
   Axel.


Other related posts: