[haiku-commits] Re: r40322 - haiku/trunk/src/tests/kits/net/preflet/ServicesAddOn

  • From: "Axel Dörfler" <axeld@xxxxxxxxxxxxxxxx>
  • To: haiku-commits@xxxxxxxxxxxxx
  • Date: Sun, 30 Jan 2011 18:08:54 +0100

kallisti5@xxxxxxxxxxx wrote:
> +             char line[1024], *linePtr;

It's also preferred to only declare a single variable per line, btw.
Also, even 'ptr' isn't really a nice name.

> -                     if (! *l)
> +                     if (! *linePtr)

The space after the ! should not be there either.

>   *           Alexander von Gluck, kallisti5@xxxxxxxxxxx
>   */
>  
> +
>  #include "NetworkSetupAddOn.h"
>  
>  class ServicesAddOn : public NetworkSetupAddOn {

Almost, there is also a second blank line after the include.

> -protected:
> -     BListView*              fServicesListView;
> -public:
> -                                     ServicesAddOn(image_id addon_image);
> -     BView*          CreateView(BRect* bounds);
> -     const char*     Name() { return "Services"; };
> -     status_t                ParseInetd();
> -     status_t                ParseXinetd();
> +     protected:
> +             BListView*                      fServicesListView;

You didn't really make this one better. As I said, please just read our 
coding style! While it might be a bit incomplete at certain things, it 
covers pretty much everything I pointed out so far.

Bye,
   Axel.


Other related posts: