[haiku-bugs] [Haiku] #8343: Why does Bootman not work and Haiku won't install/boot?

#8343: Why does Bootman not work and Haiku won't install/boot?
----------------------------------------+-------------------------
 Reporter:  Luposian                    |        Owner:  bonefish
     Type:  bug                         |       Status:  new
 Priority:  normal                      |    Milestone:  R1
Component:  Partitioning Systems/Intel  |      Version:  R1/alpha3
 Keywords:                              |   Blocked By:
 Blocking:                              |  Has a Patch:  0
 Platform:  x86                         |
----------------------------------------+-------------------------
 I installed Lubuntu on my 320Gb SATA HD on my Acer Aspire X1200.

 When I run the Haiku Live CD (from a recent build) and try running the
 installer, I can use Bootman and it sees the partitions and will address
 them as normal.  I can also install the boot sector as well.

 However, when I try to initialize the main drive (not one of the
 partitions, though I doubt that would matter), it seems to go ok, but upon
 trying to rerun Bootman, it says "No space available" in red, over the
 drive size shown.  Yet it worked fine just a moment earlier, BEFORE I
 tried initializing the drive!

 If I proceed to install Haiku onto the drive, everything seems to go
 smoothly and the system reboots... but all that pops up, after that, is
 the Haiku boot options menu and "no drive found" is the only thing shown.
 Upon trying to select a drive, there is none!  My only option is to
 reboot, which, of course, accomplishes nothing, except ending up at the
 same screen again...

 Thus, I'm in a situation where I can't install Haiku!  Am I doing
 something wrong or is something wrong with the install process?

-- 
Ticket URL: <http://dev.haiku-os.org/ticket/8343>
Haiku <http://dev.haiku-os.org>
Haiku - the operating system.

Other related posts: