[haiku-bugs] Re: [Haiku] #6177: Obsolete option -I- used

#6177: Obsolete option -I- used
---------------------------------+------------------------------------------
 Reporter:  Karvjorm             |       Owner:  nobody   
     Type:  bug                  |      Status:  new      
 Priority:  normal               |   Milestone:  R1       
Component:  - General            |     Version:  R1/alpha2
 Keywords:  obsolete option -I-  |   Blockedby:           
    Patch:  0                    |    Platform:  All      
 Blocking:                       |  
---------------------------------+------------------------------------------

Comment(by Karvjorm):

 Replying to [comment:5 siarzhuk]:
 > This is not an error, but compatibility warning - you can just ignore
 it. This option is a "separator" between local and system include paths
 and it is treated differently between gcc2.x and gcc4.x versions. So if
 you have compiled your sources - there is nothing to trouble about. ;-)
 >
 > PS: Anyway, this issue should be fixed in the future.
 OK, thanks. Then I try to study the following error messages to find
 reason why my build fails.
 {{{
 Link ../../../../generated/objects/haiku_host/x86/release/tools/settype

 rm -f "../../../../generated/objects/haiku_host/x86/release/tools/settype"
 gcc  -o
 "../../../../generated/objects/haiku_host/x86/release/tools/settype"
 "../../../../generated/objects/haiku_host/x86/release/tools/settype.o" \
  -lbe -lstdc++.r4  \


 ...failed Link
 ../../../../generated/objects/haiku_host/x86/release/tools/settype ...
 ...skipped RAWTranslator for lack of <build>settype...
 ...failed updating 1 target(s)...
 ...skipped 1 target(s)...
 }}}

-- 
Ticket URL: <http://dev.haiku-os.org/ticket/6177#comment:7>
Haiku <http://dev.haiku-os.org>
Haiku - the operating system.

Other related posts: