[haiku-bugs] [Haiku] #5533: Colors Are Incorrect (Radeon X850)

#5533: Colors Are Incorrect (Radeon X850)
-------------------------------------+--------------------------------------
 Reporter:  drcouzelis               |       Owner:  euan     
     Type:  bug                      |      Status:  new      
 Priority:  normal                   |   Milestone:  R1       
Component:  Drivers/Graphics/radeon  |     Version:  R1/alpha1
 Keywords:  Colors Radeon X850       |   Blockedby:           
 Platform:  All                      |    Blocking:           
-------------------------------------+--------------------------------------
 The colors are incorrect for the entire Haiku GUI. By "incorrect" I mean
 the wrong colors are used, and there is often a lot of pink and green.
 There are no graphical glitches; only the colors are incorrect. Please see
 the attached screenshot. I have a Radeon X850 XT PE video card. (Dec 2004,
 PCIe, codename "R480")

 No bpp setting will fix the problem (8, 15, 16, 32 bpp). As a workaround,
 if I boot Linux, reboot, and then boot Haiku, then 32 bpp is almost
 correct and 16 bpp looks correct.

 I assume the workaround works because Linux loads the Radeon "R420
 microcode". Consider adding the microcode to Haiku. I will attach the
 microcode that is used in the Linux kernel for convenience.

 This bug may be related to ticket #1700.

-- 
Ticket URL: <http://dev.haiku-os.org/ticket/5533>
Haiku <http://dev.haiku-os.org>
Haiku - the operating system.

Other related posts: