[gulfrre] charlas expo, mas del "caso de..."

  • From: Dardo Valdez <yacolinux@xxxxxxxxxxxx>
  • To: Gulfrre <gulfrre@xxxxxxxxxxxxx>
  • Date: Wed, 10 Oct 2007 08:29:30 -0300 (ART)

Gulfrre Grupo de Usuarios de Linux Facultad Regional Resistencia
----------------------------------------------------------------



Hola, estoy preparando los "papers" para proponer 2
charlas para la expo. Una sería sobre el caso de éxito
del mail de anteayer y otra sería sobre LVM.


Como dijo TL, lo que escribí un resumen muy compacto
del laburo que se hizo y se está haciendo. Hay
anécdotas que pueden ilustrar un poco el tema.

Hace un tiempo, teníamos que migrar un sistema php
interno, también era una migración de SO de Debian a
SLES10. Es un sistema LAPP y por ello había que
replicar la versión de PHP+Postgresql para hacer una
migración "transparente" (sin modificar nada más que
algunos PATHs). La cuestión fue que la app usaba php4,
y sles10 no incluía php4 en la lista de paquetes
oficiales, ídem con la versión de pgsql.

Empecé probando paquete x paquete la instalación y
resolución de dependencias usando rpms de SLES9 y
algunos rpms externos también para llegar a las
versiones "objetivo" de LAPP, requeridas por nuestra
querida aplicación. Trabajo de 6 hs/yo

Finalmente no hubo caso, todas las dependencias con
las versiones "objetivo" bien instaladas (o sea L-PP
:-) llegaban hasta un cierto rpm de apache2, que para
esta altura ya era uno "portado" de SLES9, ese paquete
presentaba incompatibilidad a nivel binario
directamente, así que sí lo podías instalar, pero
sencillamente no funcionaba (errores de segmentación
por doquier). Ahí terminó la idea de usar paquetes.

Luego propuse compilar desde cero pgsql (ya que sí
llegaba a tener Apache+php4 instalados), pero no hubo
caso con la capa 8 que quería "solo paquetes" y nada
de mantenimiento manual (ni hablar de sources rpm, que
no había tampoco).

Para terminar no se hizo nada, y se dejó el viejo
Debian corriendo la app. Aproximadamente 10 a 12
hs./yo después de comenzada la aventura.

Hace poco descubrí que Novell tiene en sus servers ftp
un directorio donde mantiene versiones viejas y nuevas
de ciertos componentes críticos (LAMP y LAPP claro),
para versiones viejas y nuevas de SLES9 y OpenSuse.
Con estos paquetes probablemente hubiera resuelto el
problema (el de la versión de pgsql específicamente),
pero sencillamente no los encontré antes (no pude
determinar si existían estos paquetes al momento de mi
trabajo igualmente).

Más allá de la futilidad del trabajo, me recordó mis
viejos tiempos con el "rpm hell" (199x, siglo XX), y
refrescó esa habilidad ya casi intuitiva para
encontrar paquetes con poca o ninguna relación, pero
sí con dependencias entre sí, jaja

Dardo A. Valdez
Adm. de Sistemas
Poder Judicial de Ctes.


      
____________________________________________________________________________________
Yahoo! Noticias
Leé la columna de "El Chavo" Fucks y encontrá una visión distinta de las 
Elecciones Presidenciales 2007 en:
Url: http://ar.news.yahoo.com/elecciones2007/opinion/1437/cualquier-verdura
 Para administrar tu cuenta: http://www.freelists.org/list/gulfrre  
 Para ver mensajes anteriores: http://www.freelists.org/archives/gulfrre     
 -----------------------------------------------------------------------

Reglas de la Lista

Añadir OT a todos los temas Off Topic
Respetar las Ideas de los miembros
No crear ni continuar con Flames

Other related posts:

  • » [gulfrre] charlas expo, mas del "caso de..."