[greenstone_es] Re: curioso comportamiento del GLI en Windows

Hola Benigno

 

Nosotros hemos experimentado este problema con anterioridad.

 

Este problema aparece cuando se importa a una colección uno o varios
documentos que en su nombre de archivo contiene algún tipo de diacrítico.
Cuando esto sucede no es posible abrir la colección sin que aparezcan los
avisos de los que hablas

 

La solución acceder directamente a la carpeta import de vuestra colección y
buscar todos los archivos que contengan algún diacrítico, luego tendréis que
cambiar el nombre de archivo manualmente.

 

Por ejemplo: imagina que tienes un archivo llamado Informe_niños.pdf
acompañado de su correspondiente documento descriptivo metadata.xml. El
documento metadata.xml contiene la siguiente línea de código que asocia el
registro bibliográfico con el archivo Informe_niños.pdf:

 

<FileName>Informe_niños\.pdf</FileName>

 

Los pasos a seguir para solucionar el problema son:

 

1. Cambiar el nombre de archivo por Informe_ninos.pdf donde como puedes
observar se cambia una ñ por una n. Una vez efectuado este cambio en el
nombre del propio archivo es necesario también efectuar el cambio
correspondiente en el documento metadata.xml cambiando la línea de código
anterior para escribir el nuevo nombre de archivo:

 

<FileName>Informe_ninos\.pdf</FileName>

 

Este paso debe repetirse para cada archivo que contenga algún diacrítico.

 

Nosotros también utilizamos Windows y hemos experimentado este problema y lo
hemos solucionado de la forma descrita.

 

Recibe un saludo

Eduardo

 

 

--

Eduard del Valle

Responsable de Digitalització i Web

Servei de Biblioteca i Documentació

Edifici Ramon Llull

Universitat de les Illes Balears

Cra de Valldemossa, km 7.5

07122 Palma de Mallorca

 

Tel:  +34 971 17 33 56

Fax: +34 971 25 96 35

  _____  

De: greenstone_es-bounce@xxxxxxxxxxxxx
[mailto:greenstone_es-bounce@xxxxxxxxxxxxx] En nombre de Del Aim
Enviado el: viernes, 04 de junio de 2010 12:54
Para: greenstone_es@xxxxxxxxxxxxx
Asunto: [greenstone_es] curioso comportamiento del GLI en Windows

 

Estimado(a)s miembros de Greenstone hispanófono,
les escribo porque hace unos días la interface GLI de nuestra base
documental construida con Greenstone presenta problemas. Llevamos ya 3 años
trabajando con ella y nunca habiamos tenido tal problema que es : utilizamos
dos sistemas de metadatos  unidos para describir nuestros documentos : DC et
DLS para completar. Hace unos dias, cuando se abrio el GLI para trabajar (en
Windows) este pedía  fusionar los dos juegos de metadatos como si no lo
estuvieran ya. Si se declina esto, pues no aparecen los campos de
descripción de DLS en el GLI. Ademas, algunas de las carpetas no estan
visibles, lo que impide continuar catalogando en el GLI. 
Al abrir la misma colección desde Linux (Mepis), el GLI marcha
correctamente. El problema es que en nuestra organización se utiliza
Windows.
Alguien tendría una idea de dónde está el problema?
Muchas gracias por anticipado.
Benigno D.

 

Other related posts: