[gptalk] Reduced GPMC Performance on Vista+SP1?

  • From: "Cruz, Jerome L" <jerome.l.cruz@xxxxxxxxxx>
  • To: "gptalk@xxxxxxxxxxxxx" <gptalk@xxxxxxxxxxxxx>
  • Date: Fri, 23 May 2008 16:15:29 -0500

I'm checking here before reporting to Microsoft.

I have been monitoring the performance of the newly updated GPMC 6.x console 
(Vista+SP1 and RSAT tools). It appears to be 'extraordinarily' slower than 
version 1.02 for Windows XP or the 2.x version released with Vista RTM (though 
admittedly I didn't use that one much).

I threw "Performance Monitor" at the mmc process that hosts it and noticed that 
it was recording literally "billions" of machine cycles before displaying data 
(while on the Scopes tab) as I browsed from GPO to GPO. This was when I was 
physically on my company's network (gigabit speed on the LAN). It takes 1-2 
minutes to display any information on the Scopes tab (less on other tabs, but 
still slow for them as well compared to XP). When accessing things from home 
while telecommuting (1,000-2,500 kbps connection), I literally have to wait 6-7 
minutes or longer to get the data visible per GPO on the Scopes tab.

My Vista device has plenty of resources (see below). I also know that for the 
GPMC to display data on the Scopes tab, it 'touches' each OU in AD to see if 
the GPO is link there (I 'really' wish MS would cache this info the first time 
and let 'me' choose when to refresh it...sigh), but since Windows XP's GPMC can 
do this in a few seconds, what's the deal with 6.x? Has anyone noted this same 
behavior? Any previous discussions on it? Any resolutions or work around?

My PC's Hardware
Dell Latitude D630 (T2400 @ 1.83 Ghz)
Vista+SP1 (32 bit) with RSAT Tools installed
2 GB RAM with ~ 800 MB Free and Available
SanDisk Cruzer Micro 2 GB USB flash drive(plugged into USB 2.0 connection and 
using about 768KB for Windows ReadyBoost)
16 GB free hard disk space

Jerry Cruz | Group Policies Product Manager | Boeing IT

Other related posts: