[gptalk] Re: Error Deploying .MSI

  • From: "Attardo, Joe" <Joe_Attardo@xxxxxxxxxxxxxx>
  • To: <gptalk@xxxxxxxxxxxxx>
  • Date: Tue, 7 Nov 2006 09:51:34 -0500

It is a home grown package, and the only one causing grief from a 2K3 DC. If I 
log on to a 2K DC, I can create the policy with no issues. 

        -----Original Message-----
        From: gptalk-bounce@xxxxxxxxxxxxx [mailto:gptalk-bounce@xxxxxxxxxxxxx] 
On Behalf Of Thorbjörn Sjövold
        Sent: Tuesday, November 07, 2006 3:13 AM
        To: gptalk@xxxxxxxxxxxxx
        Subject: [gptalk] Re: Error Deploying .MSI
        
        
        Joe,
         
        my guess is that this package does not have the proper advertising 
tables, or even worse advertising is disabled all together in the the MSI. Is 
it a home grown package or something public? When you add a package the *.aas 
file is created using the Windows Installer APIs and they rely on the 
information in the Advertising sequence. Is this the only package that behaves 
like this?
         
        Best,
        Thorbjörn Sjövold 
        Special Operations Software 
        www.specopssoft.com 
        thorbjorn.sjovold a t specopssoft.com 

        Download our free tool for remote Gpupdate with graphical reporting, 
        http://www.specopssoft.com/products/specopsgpupdate/default.asp 


________________________________

        From: gptalk-bounce@xxxxxxxxxxxxx [mailto:gptalk-bounce@xxxxxxxxxxxxx] 
On Behalf Of Darren Mar-Elia
        Sent: Monday, November 06, 2006 8:16 PM
        To: gptalk@xxxxxxxxxxxxx
        Subject: [gptalk] Re: Error Deploying .MSI
        
        

        Different MSI versions could definitely cause it. You might want to 
enable verbose software deployment logging (see my gpolog.adm for this) and see 
what messages are being thrown there.

         

        Darren

         

        
________________________________


        From: gptalk-bounce@xxxxxxxxxxxxx [mailto:gptalk-bounce@xxxxxxxxxxxxx] 
On Behalf Of Attardo, Joe
        Sent: Monday, November 06, 2006 9:44 AM
        To: gptalk@xxxxxxxxxxxxx
        Subject: [gptalk] Error Deploying .MSI

         

        I a receive the following error while trying to add a new policy for 
deploying a software package. The DC is a 2K3 server. I am able to do this when 
logged onto a Win2K DC without error. 

         

        Add Operation Failed. Unable to extract deployment information from the 
package. Run validation on the package to ensure that the package is correct. 

         

        Would this be a result of different versions of Windows Installer? 

         

        Thanks

        Joe

Other related posts: