[glideplan_swproj] Re: Plugin namespaces

  • From: Kuba Marek <blue.cube@xxxxxxxxx>
  • To: glideplan_swproj@xxxxxxxxxxxxx
  • Date: Sat, 4 Feb 2012 17:16:52 +0100

I think that using different namespaces for each plugin is good,
because name clashes between them could theoretically happen (probably
with plugins that have dependencies) and would be a little annoying to
walk around.
K

> Hi Kuba,
> yes it seems that we have no (or weak) system in namespaces. Feel
> free to create some. In my opinion, we don't need nested namespaces,
> but if you wish, do it that way.
> 
> T.
> 
> > ------------ Původní zpráva ------------
> > Od: Cestmir Houska <czestmyr@xxxxxxxxx>
> > Předmět: [glideplan_swproj] Re: Plugin namespaces
> > Datum: 04.2.2012 12:56:35
> > ----------------------------------------
> > Good Idea. Maybe Updraft:: would suffice?
> > 
> > Cestmir
> > 
> > On Fri, Feb 3, 2012 at 7:57 PM, Kuba Marek <blue.cube@xxxxxxxxx>
> > wrote:
> > > Hi,
> > > currently the namespaces used by plugins are pretty messy.
> > > igcviewer uses Updraft::Core, turnpoints use only Updraft ...
> > > what about changing it all to Updraft::PluginName ?
> > >
> > > K
> > 
> > To visit archive or unsubscribe, follow:
> > http://www.freelists.org/list/glideplan_swproj
> > 
> > 
> > 
> 
> To visit archive or unsubscribe, follow:
> http://www.freelists.org/list/glideplan_swproj

Other related posts: