[fruityloops] Re: crackling, popping and general sound distortion

  • From: "AndyEbling" <andyebling@xxxxxxxxxxx>
  • To: <fruityloops@xxxxxxxxxxxxx>
  • Date: Mon, 14 Oct 2002 22:25:33 +0100


Sorry, I accidentally posted this with a bad subject header :-#.

Here it is again, just in case it gets missed...

> I am having real problems lately with popping and crackling noises.
> This happens when I get to busy (I think)
> Basically when laying down a tune once I start added all affects and using
> the event editor its as if its to much for the pc or program to handle.

Have you tried increasing the buffer length?  To do this try:

options->Audio Settings

If you are using the DirectSound drivers, there should be a slider on the
left hand side of the dialog.  Move this towards the right.  You also may
want to experiment with "Use polling" and "Use hardware buffer" options
below the slider.  Underneath those options in the number of underruns that
have occured.  If this number is non-zero it means that your system cannot
keep up with the demands placed on it and the buffer size needs to be
increased.

If you are using the kx project ASIO drivers, then you will need to load up
the ASIO control panel and increase the buffer size there.

> I even tried exporting the whole drum track and bass track as a wav and
then
> imported them back with the idea that not as much would be processed at
> once. This seem to make no difference???

This should help, but if you don't disable the effects/channels you aren't
using anymore, you won't see a reduction in the CPU usage.

> It's not as though I am running hundreds of samples I am only talking
about
> 10 or so each with say 3 effects on. Surely it should be able to handle
> this?

Depends which effects they are.  Reverbs are particularly heavy on the CPU
and some are worse than others in this respect(not all reverbs are created
equal!).  Also bear in mind that native fruity effect plugins use less CPU
than their VST counterparts (same goes for instruments), so unless you have
particular reason to use another effect plugin, try and stick to the ones
that come with fruity.

There are some other tricks you can try to reduce CPU usage on effects.  One
is to have effects disable themselves when there is no audio passing through
them.  You can do this by:

Tools->Misc Macros->Switch Smart disable for all effects.

You can also enable this per effect using the same menu that you to select
FX presets etc.

Another trick is to share reverbs between tracks by placing a single reverb
in one of the 4 send channels and routing the appropriate amount of each on
the 16 effects channels to it.  I tend to use two reverbs, one in Send1 and
the other in Send2.  The one in Send1 has a long decay time (1.5 to 2 secs)
the one in Send2 has a shorter decay time (0.5 secs or less).  If I just
want to add a bit of ambience to a sound, I route it to Send2, however if I
want a sound to "float" in space in the mix, then I route it to send1.  Note
that if you use effects in this way in the send channels, you will want to
adjust them so that no dry signal goes through (i.e. 100% wet signal).

> Oh and just in case you need to know I have
>
> 0.8GHz processor
> 20GHz hard drive
> 128K ram
> soundblaster live ( I must get rid of this at some point ?!?! )

You don't say which OS you are running.  If you are using XP, there are a
few tricks you can use to help things in this sort of situation.  Otherwise,
you might want to try 98lite, but don't blame me if it screws up your
windows installation!

Without wanting to be rude, that is a fairly modest spec machine these days.
You should be OK if you stick to mainly sample based songs (rather than
using lots of softsynths/VSTis) and don't use too many effects.

You should also check that you aren't running anything in the background
(anti virus etc) which might be eating crucial CPU cycles at just the wrong
time.

Hope that helps,

Andy


Other related posts: