[ExchangeList] Re: message stuck in categorizer

  • From: <ChongJa@xxxxxxxxxxxxxxxx>
  • To: <exchangelist@xxxxxxxxxxxxx>
  • Date: Wed, 29 Mar 2006 17:16:53 -0500

We have a DL that has 5000+ users and we get these errors all the time, we were 
supposed to consolidate but never got around to it. This will cause some 
latency but never seen it where it would stall the queue like you mentioned. 
Some of our EX\DCs are high performance and some are terrible. But I would do 
what James has suggested, try to consolidate the group by nesting so we can at 
least eliminate this as a factor. When you rebooted (if you did both EX and DC) 
did the queue start clearing at all? Also how many GCs do you have? The only 
other time I've seen it where the queue would get stuck in the categorizer with 
no other events was due to misconfigured sites and services. We had an EX 
server querying a DC our in a remote site over slow link on slow server. The EX 
server would queue the message for up to an hour than go down by itself. If you 
have multiple GC's, you can try manually setting different GCs for dsaccess if 
you suspect a particular dc is having some issues. 

________________________________

From: exchangelist-bounce@xxxxxxxxxxxxx on behalf of James Lilly
Sent: Wed 3/29/2006 4:47 PM
To: exchangelist@xxxxxxxxxxxxx; tpkern@xxxxxxxxx
Subject: [ExchangeList] Re: message stuck in categorizer


Hey, have you seen this link?
 
http://www.eventid.net/display.asp?eventid=2074&eventno=4451&source=MSExchangeDSAccess&phase=1
 
I have also read for other versions of Exchange, that 3000 is the recommended 
maximum for a single DL.  Are you in an environment where you could change the 
group to be nested, and use two (or more) smaller groups to make up the DL?  
(Yeah, yeah, I know, it's a group, but same ol' same ol'.)
 
Also, check out this KB article, specifically the LDAP paramenter for 
MaxValRange.  I'm guessing that opnyc10.opandco.com is set to something less 
than 3000.  :)  http://support.microsoft.com/default.aspx?scid=kb;en-us;315071
 
Hope this helps;
 
James

________________________________

From: tpkern@xxxxxxxxx [mailto:exchangelist@xxxxxxxxxxxxx] 
Sent: Wednesday, March 29, 2006 3:11 PM
To: <exchangelist@xxxxxxxxxxxxx>
Subject: [ExchangeList] Re: message stuck in categorizer


I get 2 dsaccess errors-
 
Event Type: Warning
Event Source: MSExchangeDSAccess
Event Category: LDAP 
Event ID: 2074
Date:  3/29/2006
Time:  2:23:10 PM
User:  N/A
Computer: EXNYC04
Description:
Process STORE.EXE (PID=2400).  A search or read to Directory Server 
opnyc10.opandco.com returned object 'CN=DL - ALL 
USERS,OU=OPCO,OU=GROUPMAILBOXES,DC=OPANDCO,DC=COM' which has  attribute 
'member' with too many values to return in a single search.   If possible, 
reduce the number of values in this attribute to allow normal operation. 
For more information, click http://www.microsoft.com/contentredirect.asp. 
 
AND-
 

Event Type: Error
Event Source: MSExchangeDSAccess
Event Category: LDAP 
Event ID: 2061
Date:  3/29/2006
Time:  2:23:10 PM
User:  N/A
Computer: EXNYC04
Description:
Process STORE.EXE (PID=2400). An LDAP search call failed - Server= 
opnyc10.opandco.com Error code=80040904. Base DN=CN=DL - ALL 
USERS,OU=OPCO,OU=GROUPMAILBOXES,DC=OPANDCO,DC=COM, Filter=(objectclass=*), 
Scope=0. 

For more information, click http://www.microsoft.com/contentredirect.asp. 


 

 
Thanks

 


On 3/29/06, ChongJa@xxxxxxxxxxxxxxxx <ChongJa@xxxxxxxxxxxxxxxx > wrote: 

        No events? I would've expected some dsaccess events. Did you turn up 
diag for dsaccess? Take a look at this article to help troubleshoot. Verify 
that your EX can connect to your ldap and GC ports of your DC. 
        
        
http://searchexchange.techtarget.com/originalContent/0,289142,sid43_gci1119795,00.html
        
        ________________________________ 
        
        From: exchangelist-bounce@xxxxxxxxxxxxx on behalf of Todd Hofert
        Sent: Wed 3/29/2006 11:17 AM
        To: exchangelist@xxxxxxxxxxxxx 
        Subject: [ExchangeList] Re: message stuck in categorizer
        
        
        I have some concrete shoes for the user.
        
        ________________________________
        
        From: exchangelist-bounce@xxxxxxxxxxxxx 
[mailto:exchangelist-bounce@xxxxxxxxxxxxx] On Behalf Of Tom Kern
        Sent: Wednesday, March 29, 2006 11:14 AM
        To: ExchangeList 
        Subject: [ExchangeList] message stuck in categorizer
        
        
        I have a user who sent an email to almost 3000 recipents internally and 
the email is stuck in the"messages awaiting directory lookup" queue for almost 
4hrs now. 
        There is nothing logged in the app log on the exchange server(i turned 
up diag logging).
        
        There is nothjing on the GC log. Load is fine.
        
        Can anyone help me with this?
        
        
        Thanks
        
        This e-mail and any attachments may contain confidential and privileged 
        information. If you are not the intended recipient, please notify the
        sender immediately by return e-mail, delete this e-mail and destroy any
        copies. Any dissemination or use of this information by a person other 
        than the intended recipient is unauthorized and may be illegal.
        
        
        
        


Other related posts: