RE: Invalid SMTP address characters

  • From: "Michael B. Smith" <michael@xxxxxxxxxx>
  • To: "[ExchangeList]" <exchangelist@xxxxxxxxxxxxx>
  • Date: Thu, 3 Nov 2005 10:15:35 -0500

Can you send it manually?
 
What do the logs on the smart host say?
 
Did GFI auto-update on you?

________________________________

From: Chris Wall [mailto:Chris.Wall@xxxxxxxxxxxxxxxxxxx] 
Sent: Thursday, November 03, 2005 10:05 AM
To: [ExchangeList]
Subject: [exchangelist] RE: Invalid SMTP address characters


http://www.MSExchange.org/


My exchange 2003 environment forwards the e-mail to a Smart Host running
IIS 6.0 SMTP services with GFI.

 

When the users with the apostrophe in the e-mail address sends the
message, I can see in my SMTP logs (on the Smart Host) that the e-mail
attempts to deliver and the session just quits unexpectedly.  

 

GFI is not stopping the mail delivery, but the SMTP session never
completes and the e-mail appears to simply 'disappear' with no bounce
back or error.

 

When I change the Primary SMTP address to NOT contain the apostrophe,
all works well.

 

Any ideas?


Thanks,

Chris

 

________________________________

From: William Holmes [mailto:wtholmes@xxxxxxxxxxxxxx] 
Sent: Thursday, November 03, 2005 9:09 AM
To: [ExchangeList]
Subject: [exchangelist] RE: Invalid SMTP address characters

 

http://www.MSExchange.org/

Hello,

 

Was anything changed 5 days ago?  Exchange itself, domain controllers or
global catalog servers or a firewall change?  Did this change affect
sending to all external recipients of specific ones?

 

Bill

________________________________

From: Michael B. Smith [mailto:michael@xxxxxxxxxx] 
Sent: Thursday, November 03, 2005 7:59 AM
To: [ExchangeList]
Subject: [exchangelist] RE: Invalid SMTP address characters

 

http://www.MSExchange.org/

I would be interested in seeing the bounce.

 

RFC-2822 says that character is OK. That doesn't mean all mail systems
along a path would.

 

________________________________

From: Chris Wall [mailto:Chris.Wall@xxxxxxxxxxxxxxxxxxx] 
Sent: Wednesday, November 02, 2005 10:01 AM
To: [ExchangeList]
Subject: [exchangelist] Invalid SMTP address characters

http://www.MSExchange.org/

Hello all,

 

   Running Exchange 2003 Pre SP1...

   

   I have several users that have (for years) had an apostrophe in their
primary SMTP address, and they have had no problems. An Example would be
Chris.D'Wall@xxxxxxxxxxxxxxxxxxxx  Notice the ' in the example.

 

   All of a sudden, 5 days ago, all users with apostrophes in their SMTP
address have been unable to send external or receive external e-mails.
To fix the issue I have had to set their primary SMTP address to not
include the Apostrophe.  Using the example above, the new primary would
be Chris.DWall@xxxxxxxxxxxxxxxxxxxx  

 

   This would allow mail to flow from and to the users.

 

    Now the weird part - if I leave the Chris.D'Wall@xxxxxxxxxxxxxxxxxxx
address as an alias - external senders can now deliver mail to either
address. 

 

Any ideas on this one?

 

Thanks

Chris

------------------------------------------------------
List Archives: http://www.webelists.com/cgi/lyris.pl?enter=exchangelist
Exchange Newsletters: http://www.msexchange.org/pages/newsletter.asp 
------------------------------------------------------
Visit TechGenix.com for more information about our other sites:
http://www.techgenix.com
------------------------------------------------------
You are currently subscribed to this MSExchange.org Discussion List as:
michael@xxxxxxxxxx
To unsubscribe visit
http://www.webelists.com/cgi/lyris.pl?enter=exchangelist
Report abuse to listadmin@xxxxxxxxxxxxxx
------------------------------------------------------
List Archives: http://www.webelists.com/cgi/lyris.pl?enter=exchangelist
Exchange Newsletters: http://www.msexchange.org/pages/newsletter.asp 
------------------------------------------------------
Visit TechGenix.com for more information about our other sites:
http://www.techgenix.com
------------------------------------------------------
You are currently subscribed to this MSExchange.org Discussion List as:
wtholmes@xxxxxxxxxxxxxx
To unsubscribe visit
http://www.webelists.com/cgi/lyris.pl?enter=exchangelist
Report abuse to listadmin@xxxxxxxxxxxxxx 

------------------------------------------------------
List Archives: http://www.webelists.com/cgi/lyris.pl?enter=exchangelist
Exchange Newsletters: http://www.msexchange.org/pages/newsletter.asp 
------------------------------------------------------
Visit TechGenix.com for more information about our other sites:
http://www.techgenix.com
------------------------------------------------------
You are currently subscribed to this MSExchange.org Discussion List as:
Chris.Wall@xxxxxxxxxxxxxxxxxxx
To unsubscribe visit
http://www.webelists.com/cgi/lyris.pl?enter=exchangelist
Report abuse to listadmin@xxxxxxxxxxxxxx 

------------------------------------------------------
List Archives: http://www.webelists.com/cgi/lyris.pl?enter=exchangelist
Exchange Newsletters: http://www.msexchange.org/pages/newsletter.asp 
------------------------------------------------------
Visit TechGenix.com for more information about our other sites:
http://www.techgenix.com
------------------------------------------------------
You are currently subscribed to this MSExchange.org Discussion List as:
michael@xxxxxxxxxx
To unsubscribe visit
http://www.webelists.com/cgi/lyris.pl?enter=exchangelist
Report abuse to listadmin@xxxxxxxxxxxxxx 

Other related posts: