RE: Exchange Disaster Recovery - Help Required

  • From: "Wehbe, Wissam" <Wissam.Wehbe@xxxxxxxxxx>
  • To: "[ExchangeList]" <exchangelist@xxxxxxxxxxxxx>
  • Date: Thu, 7 Feb 2002 14:34:15 +0400

Great, I did this exercise three times and you can make it. 
 
Please follow the steps below, don't leave any one of them, this is what
I did and it will work. 
 
Recovery Steps

*       Manually remove Exchange completely from the computer. To do
this, follow these steps: 

        In HKEY_LOCAL_MACHINE \CurrentControlSet \Services, remove all
keys relating to Exchange 2000 services and drivers from the registry.
These include: 


*       DAVEX 

*       ESE97 

*       ESE98 

*       EXIFS 

*       ExIPC 

*       EXOLEDB 

*       IMAP4Svc 

*       MSSEARCH 

*       POP3Svc 

*       RESvc 

*       Anything that starts with LME- 

*       Anything that starts with MSExchange 

*       Anything that starts with SERVERNAME-LME 

*       Remove the Exchange Setup key from the HKEY_LOCAL_MACHINE
\Software \Microsoft \Exchange registry key entirely. 

*       Rename the Exchsrvr folders on all disks on the computer. 

*       Restart the server. 
*       Delete the renamed Exchsrvr folders from the system. 
*       From the Exchange Server 5.5 installation compact disc, run
setup /r. Choose the same installation choices that were on the original
server. Choose to create a new site with the same organization and site
names. 
*       When Setup finishes, run Performance Optimizer, and configure
the file locations to the same places in which the files were located
before. 
*       From the appropriate Exchange Server 5.5 service pack compact
disc, run update /r. 
*       Install any post-service pack hotfixes that were previously on
the server. 
*       Restore the directory and information store from a previous
backup. 
*       Start the Exchange Services 
*       Force intrasite directory replication. 

 
and enjoy your Exchange again :)) 
 
 
Regards
 
Wissam 
 
 
From: Deshwal Chand [mailto:chand@xxxxxxxxxxxxxxxxx]
Sent: 07 February 2002 12:42 PM
To: [ExchangeList]
Subject: [exchangelist] RE: Exchange Disaster Recovery - Help Required


http://www.MSExchange.org/


Hi WIssam,
 
Thanx for the response.
 
Yes, I have the directory database as well. But I was trying to recover
only the Information Store as I do need only few mailboxes.
 
Regards,
Chand Deshwal (M.Tech CS&E,  MCSE, CCNA)
Network Administrator
Kampsax India Ltd., Gurgaon
ph: +91 124 6348259-62, Extn. 712
chand@xxxxxxxxxxxxxxxxx
http://www.kampsaxindia.com <http://www.kampsaxindia.com/> 
 
-----Original Message-----
From: Wehbe, Wissam [mailto:Wissam.Wehbe@xxxxxxxxxx]
Sent: Thursday, February 07, 2002 3:08 PM
To: [ExchangeList]
Subject: [exchangelist] RE: Exchange Disaster Recovery - Help Required


http://www.MSExchange.org/


Did you get the directory Database
 
WIssam 
-----Original Message-----
From: Deshwal Chand [mailto:chand@xxxxxxxxxxxxxxxxx]
Sent: 07 February 2002 10:19 AM
To: [ExchangeList]
Subject: FW: Exchange Disaster Recovery - Help Required
Importance: High


HI,
 
I have a really tough job at hands.
 
S C E N A R I O
 
We had Exchange 5.0, installed at a WindowsNT Server 4.0 with service
pack 5 installed. The Information and Directory store were on one
partition of the disk and the logs were on other partition. The hard
disk failed. Unfortunately, there was no backup taken for 10 days. (No
backup at all!). Somehow, it was managed that the PRIV.EDB and PUB.EDB
could be retrieved from the crashed hard drive. Only these two files
were managed to be retrieved. 
 
PRIV.EDB is 3 GB of size and PUB.EDB is 1 MB in size. 
 
But the person at that time were not able to get it working. I have been
trying to restore the same.
 
What I have done?
 
1. Installed NT 4.0 with service pack 5 at some other machine (NT server
as PDC for some test domain)
2. Installed Exchange 5.0 on the machine. 
3. Stopped the Information Store service of Exchange and copied the
PRIV.EDB abd PUB.EDB file into the MDBDATA directory. In the MDBDATA
directory only these two files were left. All the logs were deleted.
 
4. Changed to exchsrvr\bin directory and ran ISINTEG -PATCH . 
 
This gives a warning: Warning, The Private Information Store could not
be found. Assuming -Public -Only
Now if I try to run the information store service, it terminates with
the sevrice specific error: 4294966095, which is described as  -1201
0xFFFFFB4F  JET_errDatabaseDuplicate      Database already exists
4294966095 in Microsoft references.
 
If I try to run "edbutil /d /r /ispriv /tx:\tempdfg.edb, then says,
operation terminated with error: 550.

                    edbutil /d /r /ispub /tx:\tempdfg.edb runs
successfully.
 
 
I have found out the state of the PRIV.EDB. It is in the Inconsistent
State.
 
I have no way now.
 
Could any of you guys help me!


 
Regards,
Chand Deshwal (M.Tech CS&E,  MCSE, CCNA)
Network Administrator
Kampsax India Ltd., Gurgaon
ph: +91 124 6348259-62, Extn. 712
chand@xxxxxxxxxxxxxxxxx
http://www.kampsaxindia.com <http://www.kampsaxindia.com/> 
 
 
------------------------------------------------------
You are currently subscribed to this MSExchange.org Discussion List as:
chand@xxxxxxxxxxxxxxxxx
To unsubscribe send a blank email to
$subst('Email.Unsub') 
------------------------------------------------------
You are currently subscribed to this MSExchange.org Discussion List as:
WISSAM.WEHBE@xxxxxxxxxx
To unsubscribe send a blank email to
$subst('Email.Unsub') 

Other related posts: