[ell-i-developers] some problemas with stlink: unknown id!?

  • From: Eero Hakala <eero.k.hakala@xxxxxxxxx>
  • To: ell-i-developers <ell-i-developers@xxxxxxxxxxxxx>
  • Date: Fri, 29 Aug 2014 20:00:32 +0300

So what on earth is going on, how do you get the stuff from unix uploaded
into our stm32F334 nucleo board? With st-util I get this error message:
eero@eibari:~/sula/stlink$ sudo ./st-util -v99
2014-08-29T19:32:42 DEBUG src/stlink-common.c: stlink current mode: debug
(jtag or swd)
2014-08-29T19:32:42 DEBUG src/stlink-common.c: stlink current mode: debug
(jtag or swd)
2014-08-29T19:32:42 INFO src/stlink-common.c: Loading device parameters....
2014-08-29T19:32:42 DEBUG src/stlink-common.c: *** stlink_core_id ***
2014-08-29T19:32:42 DEBUG src/stlink-common.c: core_id = 0x2ba01477
2014-08-29T19:32:42 DEBUG src/stlink-common.c: *** stlink_read_debug32
10016438 is 0xe0042000
2014-08-29T19:32:42 WARN src/stlink-common.c: unknown chip id! 0x10016438
2014-08-29T19:32:42 DEBUG src/stlink-common.c: *** looking up stlink version
2014-08-29T19:32:42 DEBUG src/stlink-common.c: st vid         = 0x0483
(expect 0x0483)
2014-08-29T19:32:42 DEBUG src/stlink-common.c: stlink pid     = 0x374b
2014-08-29T19:32:42 DEBUG src/stlink-common.c: stlink version = 0x2
2014-08-29T19:32:42 DEBUG src/stlink-common.c: jtag version   = 0x14
2014-08-29T19:32:42 DEBUG src/stlink-common.c: swim version   = 0x4
2014-08-29T19:32:42 DEBUG src/stlink-common.c: *** stlink_reset ***
2014-08-29T19:32:42 INFO gdbserver/gdb-server.c: Chip ID is 00000438, Core
ID is  2ba01477.
2014-08-29T19:32:42 DEBUG src/stlink-common.c: *** reading target voltage
2014-08-29T19:32:42 DEBUG src/stlink-common.c: target voltage = 3234mV
2014-08-29T19:32:42 INFO gdbserver/gdb-server.c: Target voltage is 3234 mV.
2014-08-29T19:32:42 INFO gdbserver/gdb-server.c: Listening at *:4242...


and the st-flash doesn't want to play with me either:
eero@eibari:~/sula/stlink$ sudo ./st-flash --reset write
../RIOT/examples/hello-world/bin/stm32f3discovery/hello-world.hex 0x8000000
2014-08-29T19:41:45 INFO src/stlink-common.c: Loading device parameters....
2014-08-29T19:41:45 WARN src/stlink-common.c: unknown chip id! 0x10016438

So how do you flash stuff into that d....d board?


By the way, anybody done a led blinking program with RIOT as there is no
such example there?


-eero-

Other related posts: