[argyllcms] Re: Argyll GUI

Am Samstag, 9. August 2008 schrieb Gerhard Gaußling:
> Thank you Steve! I really appreciate your efforts to build a GUI for
> ArgyllCMS.
>
> I'll report how the installation goes. Unfortunately I'm not very
> familiar with argyllcms, but I'll report my experiences with this
> linux version. 

gerhard@ubuntu:~$ /home/gerhard/Desktop/Stuff/CMS/prog/ArgyllCMS/argyllgui 
/home/gerhard/Desktop/Stuff/CMS/prog/ArgyllCMS/argyllgui: error while 
loading shared libraries: libwxcode_gtk2u_propgrid-2.8.so.0: cannot 
open shared object file: No such file or directory
gerhard@ubuntu:~$ dpkg -S libwxcode_gtk2u_propgrid-2.8.so.0
dpkg: *libwxcode_gtk2u_propgrid-2.8.so.0* not found.
gerhard@ubuntu:~$ dpkg -S libwxcode_gtk2u_propgrid
dpkg: *libwxcode_gtk2u_propgrid* not found.
gerhard@ubuntu:~$ dpkg -S libwxcode
dpkg: *libwxcode* not found.
gerhard@ubuntu:~$ dpkg -S propgrid
dpkg: *propgrid* not found.
gerhard@ubuntu:~$ dpkg -S libwx|awk -F: '{print $1}'|sort -u
libwxbase2.6-0
libwxbase2.6-dbg
libwxbase2.6-dev
libwxbase2.8-0
libwxgtk2.4-1
libwxgtk2.4-dev
libwxgtk2.6-0
libwxgtk2.6-dbg
libwxgtk2.6-dev
libwxgtk2.8-0
vlc

gerhard@ubuntu:~$ sudo apt-get install libwxgtk2.8-0 libwxgtk2.6-dev 
libwxgtk2.6-dbg libwxgtk2.6-0 libwxgtk2.4-dev libwxgtk2.4-1 
libwxbase2.8-0 libwxbase2.6-dev libwxbase2.6-dbg libwxbase2.6-0
[sudo] password for gerhard: 
Reading package lists... Done
Building dependency tree       
Reading state information... Done
libwxgtk2.8-0 is already the newest version.
libwxgtk2.8-0 set to manually installed.
libwxgtk2.6-dev is already the newest version.
libwxgtk2.6-dbg is already the newest version.
libwxgtk2.6-0 is already the newest version.
libwxgtk2.4-dev is already the newest version.
libwxgtk2.4-1 is already the newest version.
libwxbase2.8-0 is already the newest version.
libwxbase2.8-0 set to manually installed.
libwxbase2.6-dev is already the newest version.
libwxbase2.6-dbg is already the newest version.
libwxbase2.6-0 is already the newest version.
0 upgraded, 0 newly installed, 0 to remove and 1 not upgraded.

I expect that it's not installable on ubuntu, due to wxwidget libs that 
are not in the package repositories.

This is ubuntu 8.04 hardy heron amd64.

gerhard@ubuntu:~$ apt-cache search wx gtk2
libwxbase2.4-1 - wxBase library (runtime) - non-GUI support classes of 
wxWindows toolkit
libwxbase2.6-0 - wxBase library (runtime) - non-GUI support classes of 
wxWidgets toolkit
libwxbase2.8-0 - wxBase library (runtime) - non-GUI support classes of 
wxWidgets toolkit
libwxgtk2.4-1 - wxWindows Cross-platform C++ GUI toolkit (GTK+ runtime)
libwxgtk2.4-1-contrib - wxWindows Cross-platform C++ GUI toolkit 
(runtime contrib libs)
libwxgtk2.4-contrib-dev - wxWindows Cross-platform C++ GUI toolkit 
(development contrib libs)
libwxgtk2.4-dbg - wxWindows Cross-platform C++ GUI toolkit (GTK+ 
development)
libwxgtk2.4-dev - wxWindows Cross-platform C++ GUI toolkit (GTK+ 
development)
libwxgtk2.6-0 - wxWidgets Cross-platform C++ GUI toolkit (GTK+ runtime)
libwxgtk2.6-dbg - wxWidgets Cross-platform C++ GUI toolkit (GTK+ 
development)
libwxgtk2.6-dev - wxWidgets Cross-platform C++ GUI toolkit (GTK+ 
development)
libwxgtk2.8-0 - wxWidgets Cross-platform C++ GUI toolkit (GTK+ runtime)
libwxgtk2.8-dbg - wxWidgets Cross-platform C++ GUI toolkit (GTK+ 
development)
libwxgtk2.8-dev - wxWidgets Cross-platform C++ GUI toolkit (GTK+ 
development)
python-wxgtk2.4 - wxWindows Cross-platform C++ GUI toolkit (wxPython 
binding)
python-wxgtk2.6 - wxWidgets Cross-platform C++ GUI toolkit (wxPython 
binding)
python-wxgtk2.6-dbg - wxWidgets Cross-platform C++ GUI toolkit (wxPython 
binding, debug version)
python-wxgtk2.8 - wxWidgets Cross-platform C++ GUI toolkit (wxPython 
binding)
python-wxgtk2.8-dbg - wxWidgets Cross-platform C++ GUI toolkit (wxPython 
binding, debug version)




Other related posts: